Répondre

Geneweb sur Ubuntu [Résolu]

potierb
male
Messages : 6
Saisie : Geneweb
Voir son arbre
Bonjour,

Suite à un changement de système d'exploitation (passage à xubuntu 15.10), j'ai dû réinstaller et reparamétrer geneweb.
J'avais auparavant bien fait mes sauvegardes, édité des fichiers .gw, mais c'est mon ancien répertoire /var/lib/geneweb que je voulais réutiliser.
J'ai donc relu les bons conseils reçus lors de mon post précédent (http://www.geneanet.org/forum?lang=fr&topic=530250.0).

J'ai installé geneweb avec les trois paquets geneweb, gwsetup et gwtp. Sans problème.
Je suis passé en mode superutilisateur et j'ai substitué mon ancien dossier /var/lib/geneweb (ma sauvegarde) à celui (vide de données généalogiques) qui préexistait (commande sudo thunar pour avoir le droit de le faire).
Je me suis ensuite rajouté au groupe geneweb (Menu/Paramètres, puis aller dans "Utilisateurs et groupes")
Je pouvais alors lire mes bases, mais pas les modifier. Je m'y attendais.

Là, effectivement la doc ubuntu est très utile.

J'ai tapé les commandes suivantes :

D'abord une commande inutile :
sudo chown -R geneweb /var/lib/geneweb/base04.gwb (c'est avec ma base 04 que j'ai testé)
inutile car la commande suivante me permet de débloquer toutes mes bases, et pas que la 04.

Donc il suffit sans doute de taper alors :
sudo chown -R bertrand /var/lib/geneweb
ce qui me donne les droits sur ce dossier,
puis clic droit sur ce dossier geneweb, aller dans permissions, puis autoriser la lecture et l'écriture.
Là, ça marche sur toutes les bases.

Le prochain test sera de voir si je peux créer un fichier .gw ou .ged (sauvegarde de mes bases) utilisable sur mon autre ordi.
Encore une fois, je suis satisfait de geneweb, j'ai réussi la transition assez vite et je peux me remettre à mes saisies généalogiques.

guillaumebrochu
guillaumebrochu
Messages : 101
Saisie : Geneweb
Voir son arbre
À mon avis, il aurait été préférable de faire :

Code : Tout sélectionner

sudo chgrp -r geneweb /var/lib/geneweb
sudo chmod -r 774 /var/lib/geneweb
De plus, il est bon de savoir ceci:
http://anonscm.debian.org/cgit/collab-maint/geneweb.git/tree/debian/README.debian a écrit :
Users who want to share databases in the main directory (/var/lib/geneweb)
have to be members of the geneweb group (just like the geneweb user is).
All files and directories there should be writable by the owning user AND
the geneweb group. This means that you should use 002 as umask when writing
to this directory.
Users with the more common 022 umask must then
temporarily change it before creating files, or need to adapt
directories and files permissions in /var/lib/geneweb after adding
a database.

This inludes files in the base.gwb directory as well as files created
by the daemon during its work (such as "history" of .lck files...)
should be writable by both the database owner (for allowing him for
manually make modifications from the shell) and the geneweb group.
Personnellement, pour adapter mon umask avec Debian, j'ai édité mon fichier ~/.profile

Code : Tout sélectionner

# the default umask is set in /etc/profile; for setting the umask
# for ssh logins, install and configure the libpam-umask package.
umask 002
mais il existe probablement d'autres façon d'arriver au même but.
Voici ma version personnelle pré-compilée de Geneweb 7, compatible dans les deux sens avec Geneanet :o
Je vous invite aussi à consulter le Wiki de GeneWeb
:ugeek:

Répondre

Revenir à « GeneWeb »