Répondre

Bug import média

cvramant
male
Messages : 123
Saisie : Geneweb
Voir son arbre
Bonjour,

Je possède la version Hérédis 2020 (Mac). Je suis en train de migrer vers la gestion de sources avec citations.

Jusqu'ici, je créais 1 source = 1 acte (avec média)

Je suis en train de migrer vers 1 source = 1 référence (un registre par exemple), et je créé des citations pour chaque source, sous les personnes concernées.

Autant les médias associés à mon ancienne classification sont bien pris en compte sur Généanet lors de l'import de Ged, autant les médias que j'ajoute dans les Citations ne sont absolument pas pris en compte.

S'agit-il d'un bug, d'une limitation, ou d'un autre problème ?

Ex. d'entrée avec média OK (ancienne classification) : https://gw.geneanet.org/cvramant_w?lang=fr&p=alfred+augustin&n=lhotout

Ex. d'entré avec média non uploadé (nouvelle classification) : https://gw.geneanet.org/cvramant_w?lang=fr&p=francois&n=drege

Le média joint à cet individu est cette image, bien présente dans le dossier des médias lors de l'import, il n'y a donc pas de raison qu'elle n'apparaisse pas.

Merci de votre retour :-)
Pièces jointes
Inh de François DRÈGE.jpg

cvramant
male
Messages : 123
Saisie : Geneweb
Voir son arbre
Bonjour,

J'utilise Hérédis 2020 (mac) et mon export GED n'est pas bien traité par Généanet : les médias attachés à des sources sont OK, mais les médias dans les citations de sources ne passent pas.

CI-joint une copie d'écran de ma citation de source dans Hérédis (avec le média lié), de la source liée à la personne, et de la source "générale" dans Hérédis.

Ce média est bien dans l'export GED, pourtant il n'apparait pas sur Généanet, dans cette fiche : https://gw.geneanet.org/cvramant_w?lang=fr&p=francois&n=drege

A noter que la transcription, présente seulement dans la citation, est bien exportée, elle.

Merci de votre aide
Pièces jointes
Capture d’écran 2020-01-25 à 12.52.50.png
Capture d’écran 2020-01-25 à 13.00.26.png
Capture d’écran 2020-01-25 à 13.00.39.png
Capture d’écran 2020-01-25 à 13.43.57.png

thetienne
thetienne
Messages : 1043
Saisie : Geneweb
Voir son arbre
Bonjour,
que voulez vous dire par "ne passe pas" ?
Vous avez un message d'erreur avec Geneanet Upload (*) ?

Cordialement
Thierry
(*) : cf ici si vous ne l'utilisez pas; l'envoi du fichier GED n'est pas suffisant pour envoyer les photographies/images
https://www.geneanet.org/product/upload
Geneweb, Heredis 2020 Pro, Géneatique MX à 2020 sans limites
Windows 10 - Version 2004, Debian 10.4 _____________________________________________________________________________
Ne postez pas de messages sur un fil sans rapport direct avec le sujet discuté; Dans ce cas, créez un autre sujet de discussion.

cvramant
male
Messages : 123
Saisie : Geneweb
Voir son arbre
Non c’est simplement que l’image n’apparaît pas dans la fiche, alors qu’elle devrait l’être. J’en déduis donc qu’elle n’est pas uploadee ou qu’elle n’est pas prise en compte par Geneanet lors de l’import.

thetienne
thetienne
Messages : 1043
Saisie : Geneweb
Voir son arbre
Si il n'y a pas de message sur "geneanet upload" c'est qu'elle est peut être uploadée.
Est-ce que elle est dans la rubrique "Mes documents" sur Geneanet ?
https://www.geneanet.org/media/manager

Thierry
Geneweb, Heredis 2020 Pro, Géneatique MX à 2020 sans limites
Windows 10 - Version 2004, Debian 10.4 _____________________________________________________________________________
Ne postez pas de messages sur un fil sans rapport direct avec le sujet discuté; Dans ce cas, créez un autre sujet de discussion.

cvramant
male
Messages : 123
Saisie : Geneweb
Voir son arbre
Malheureusement non, aucune trace dans Mes Documents :-(

Toutes les images présentes directement dans "Sources" dans Hérédis passent bien (et sont présentes dans "Mes Documents" sur Généanet), mais les images dans les Citations sur Hérédis sont ignorées de Généanet, alors que l'export Ged depuis Hérédis les exporte bien.

thetienne
thetienne
Messages : 1043
Saisie : Geneweb
Voir son arbre
Je viens d'essayer avec ma version 2020 sur PC
Je n'ai pas le problème avec les 2 méthodes; "Geneanet Upload" télécharge bien les 2 cas.
- Le média dans les sources est bien importé
- Le média attaché à l'événement aussi (mais ce n'est pas en citation)

Donc c'est mystérieux, il y a peut être une différence entre la version mac et PC ou c'est moi qui n'arrive pas à créer un média en citation.
en tant que media attaché à la source globale j'ai bien une ligne 1 OBJE @xx@ dans la structure SOUR
en tant que media attaché/cité dans l'événement j'ai bien une ligne 2 OBJE @yyy@ dans l'évènement.

Pour moi il n'y a pas de média en citation de la source dans HEREDIS PC (ie pas de ligne 3 OBJE @zzzz@ dans la structure SOURCE_CITATION). Comment faites vous pour creer une citation avec un média ? (La norme gedcom le permet)
26/01/2020 : Je m'aperçois que je n'avais jamais utilisé le "mode complet" d'HEREDIS pour les sources. (cf préférences HEREDIS).
Cela produit bien une ligne "3 OBJE @zzzz@" dans la citation de la source dans le GEDCOM; donc pas de problème dans HEREDIS

Cordialement
Thierry
Dernière modification par thetienne le 26 janvier 2020, 09:18, modifié 4 fois.
Geneweb, Heredis 2020 Pro, Géneatique MX à 2020 sans limites
Windows 10 - Version 2004, Debian 10.4 _____________________________________________________________________________
Ne postez pas de messages sur un fil sans rapport direct avec le sujet discuté; Dans ce cas, créez un autre sujet de discussion.

thetienne
thetienne
Messages : 1043
Saisie : Geneweb
Voir son arbre
Bonjour,
Il y a bien un bug dans Geneanet Upload, il ne prend pas en compte les medias associés dans les citations des sources structurées Dans le GEDCOM cela donne quelque chose du genre dans un événément (cas HEREDIS) :

Code : Tout sélectionner

2 SOUR @3@
3 NOTE Note de la citation
3 PAGE info_vue/page
3 QUAY qualité_source
...
3 OBJE @refsource@
...
Les tag OBJE de niveau 3 (tags pour les medias) dans les citations des sources (après les lignes "2 SOUR..." ) ne sont pas pris en compte par "Geneanet Upload" (ignorées)
Si vous supprimez le fichier associé (en laissant le lien dans le GEDCOM), ça ce voit car il ne génére pas de message disant que le fichier est manquant.

Donc à regarder par geneanet lundi, "Geneanet Upload" ne décode pas les médias cités dans les citations des sources structurées d'un événement (*)


Cordialement
Thierry
(*) extrait norme GEDCOM 5.5.1
n SOUR @<XREF:SOUR>@
+1 PAGE <WHERE_WITHIN_SOURCE> {0:1}

+1 <OBJE @<XREF:OBJE>@ {0:M}
+1 <<NOTE_STRUCTURE>> {0:M}
+1 QUAY <CERTAINTY_ASSESSMENT> {0:1}
PS : Merci au moderateur(trice) d'avoir déplacé le sujet à ma demande dans ce sous-forum et d'avoir supprimé le message redondant dans le sous-forum HEREDIS.
Dernière modification par thetienne le 26 janvier 2020, 17:28, modifié 1 fois.
Geneweb, Heredis 2020 Pro, Géneatique MX à 2020 sans limites
Windows 10 - Version 2004, Debian 10.4 _____________________________________________________________________________
Ne postez pas de messages sur un fil sans rapport direct avec le sujet discuté; Dans ce cas, créez un autre sujet de discussion.

cvramant
male
Messages : 123
Saisie : Geneweb
Voir son arbre
Bonjour,

Merci beaucoup Thierry, savez-vous comment nous seront informé du bug s'il est résolu ?

Encore merci :-)

thetienne
thetienne
Messages : 1043
Saisie : Geneweb
Voir son arbre
Normalement, l'assistance technique devrait passer sur ce post lundi et y répondre.
(attendre un ou 2 jours avant de relancer, sinon il est toujours possible de faire un ticket contact pour signaler, mais en général les modérateurs signalent ce genre de problème et geneanet les analyse).

Par contre pas évident que la solution soit rapide.

En vous souhaitant un bon week-end.
Cordialement
Thierry
Geneweb, Heredis 2020 Pro, Géneatique MX à 2020 sans limites
Windows 10 - Version 2004, Debian 10.4 _____________________________________________________________________________
Ne postez pas de messages sur un fil sans rapport direct avec le sujet discuté; Dans ce cas, créez un autre sujet de discussion.

cvramant
male
Messages : 123
Saisie : Geneweb
Voir son arbre
Top, merci Thierry :-)

assistance
assistance
Administratrice
Messages : 21789
Saisie : Geneweb
Voir son arbre
Bonjour,

J'ai transmis vos messages à l'équipe technique et reviendrai vers vous dès que possible. Merci de bien vouloir patienter.
Cordialement,
Sylvie, Responsable assistance Geneanet
-------------------------------
Foire aux questions : FAQ
Toute l'info généalogique est sur Le Blog Généalogie
Pour être informé des évolutions du site : newsletter

cvramant
male
Messages : 123
Saisie : Geneweb
Voir son arbre
Merci Sylvie, c'est noté :-)

cvramant
male
Messages : 123
Saisie : Geneweb
Voir son arbre
Bonjour, toujours aucune nouvelle de ce bug ?

assistance
assistance
Administratrice
Messages : 21789
Saisie : Geneweb
Voir son arbre
Bonjour,

Notre équipe technique est prévenue, elle corrigera le problème dès que possible, mais nous ne pouvons malheureusement pas vous indiquer de délai précis. Vous serez prévenu lors de la correction. Merci de votre compréhension.
Cordialement,
Sylvie, Responsable assistance Geneanet
-------------------------------
Foire aux questions : FAQ
Toute l'info généalogique est sur Le Blog Généalogie
Pour être informé des évolutions du site : newsletter

Répondre

Revenir à « Documents, médias et Geneanet Upload »